High Ping

#1
Excited to see eViL-mAnIa back!
Of my 264 hours on L4D2, I can say with certainty they were all spent on your server.

As a player based in mid-western US I'm getting pings around 250-300
Not unplayable but pretty dismal, When I used to play often (couple years ago) my pings were much better.
I can't say for sure on numbers, but full green bars maybe 60-80.
If I remember correctly you had three UK servers named like [eViL-mAnIa I(UK)] [eViL-mAnIa II(UK)] [eViL-mAnIa III(UK)]
and then also three servers that were just called [eViL-mAnIa I] [eViL-mAnIa II] [eViL-mAnIa III]
I assumed the second set of three servers were American based.
It's been so long It's hard to remember.

I guess what I'm getting at is, I'm assuming there isn't a US server yet, based on my uncharacteristically low ping.
If that's true, then something I feel that should be prioritized is opening a North American Server.
If not, and those are American servers, I guess me and my IP need to have a talk.

Anyways, It is an absolute delight to see [eViL-mAnIa] back online! Keep up this fantastic work!
 
Last edited:

evilmaniac

Administrator
Staff member
#2
Excited to see eViL-mAnIa back!
Of my 264 hours on L4D2, I can say with certainty they were all spent on your server.

As a player based in mid-western US I'm getting pings around 250-300
Not unplayable but pretty dismal, When I used to play often (couple years ago) my pings were much better.
I can't say for sure on numbers, but full green bars maybe 60-80.
If I remember correctly you had three UK servers named like [eViL-mAnIa I(UK)] [eViL-mAnIa II(UK)] [eViL-mAnIa III(UK)]
and then also three servers that were just called [eViL-mAnIa I] [eViL-mAnIa II] [eViL-mAnIa III]
I assumed the second set of three servers were American based.
It's been so long It's hard to remember.

I guess what I'm getting at is, I'm assuming there isn't a US server yet, based on my uncharacteristically low ping.
If that's true, then something I feel that should be prioritized is opening a North American Server.
If not, and those are American servers, I guess me and my IP need to have a talk.

Anyways, It is an absolute delight to see [eViL-mAnIa] back online! Keep up this fantastic work!
The existing server is actually in the US. It is located in Washington state. There might be something else causing the high latency.
Running some tests from the server to your IP address; I can see things are averaging out at around 99ms from the server to you.